Struggling with output on Mac OSX

Scan Tailor specific announcements, releases, workflows, tips, etc. NO FEATURE REQUESTS IN THIS FORUM, please.

Moderator: peterZ

Post Reply
Posts: 1
Joined: 19 Apr 2022, 04:45
Number of books owned: 0
Country: United Kingdom

Struggling with output on Mac OSX

Post by Skypir5 »

I've written the same query on the relevant github thread but I'm not sure how often it's frequented. I'm writing this with the hope that others try to use Scantailor on a mac. I've recorded a video of me trying it but the error message below is basically what comes up.

First off, let me say how grateful I am to have stumbled upon this amazing programme and the dedicated people who have put it together and continue to update and fix it. I am indebted to Digital Orientalist's guide on installing. Everything works beautifully right up until the output step. I have tried many things, including uninstalling the whole package, homebrew etc., reinstalling, going again. Thinking it had something to do with the content selector including space from off the page, I also methodically went through and ensured this wasn't the case. I've also spent a while trawling the internet to try and find

It's quite possible (likely?) that the error occurs at the de-warping stage, which I find to be excellent and would love to be able to use! The transformation of the pages is incredible.

This is the error message I receive:

The action “Run Shell Script” encountered an error: “qt.qpa.fonts: Populating font family aliases took 482 ms. Replace uses of missing font family "Serif" with one that exists to avoid this cost.
Qt Concurrent has caught an exception thrown from a worker thread.
This is not supported, exceptions thrown in worker threads must be
caught before control returns to Qt Concurrent.
libc++abi: terminating with uncaught exception of type std::invalid_argument: fillMarginsInPlace: the content area exceeds image rect.”

On a related note, could anyone enlighten me as to what "Qtcodes" are and whether I have them or need to install them or something? I've tried googling and reading a lot and still can't find a particularly straightforward explanation. The same applies to the bundler referenced on this forum.

This page has info on needing QT on a mac but it installs Scan Tailor using Macports and not Homebrew. There is also some nice help on using Scantailor experimental here, including these packages: "cmake eigen qt5 jpeg libtiff boost". No one has written about needing these for Scantailor advanced but maybe I should install them?

I apologise in advance for not being the most savvy at running things from Terminal. I'm doing my best at trying to learn though! Many thanks in advance.
Posts: 1
Joined: 21 Aug 2022, 15:41
Number of books owned: 0
Country: US

Re: Struggling with output on Mac OSX

Post by pronoiac »

Oof, around the same time you posted this, I was working on streamlining "Scantailor in Docker":

From memory, git clone the repo, mkdir data for all the input and output files, and check out the readme and Makefile. It uses Homebrew for local dependencies. You could probably pull the docker image, but I usually opt for building instead.

This uses the Linux release of Scantailor Advanced, and I used this on macOS Catalina. I looked for the GitHub thread or issue you mentioned, and came up empty.
Post Reply